Двумерный поиск в Excel - Microsoft Excel для начинающих > Спринг Офис
Спринг Офис    

Двумерный поиск в Excel - Microsoft Excel для начинающих


В этом примере мы объясним вам, как искать значения в двумерном диапазоне. Мы будем использовать функции MATCH (ПОИСКПОЗ) и INDEX (ИНДЕКС).

На рисунке ниже вы видите график продаж различных видов мороженого в каждом месяце.

  1. Чтобы найти номер строки Feb (февраль), используйте функцию MATCH (ПОИСКПОЗ):

    =MATCH(G2,A2:A13,0)
    =ПОИСКПОЗ(G2;A2:A13;0)

  2. Чтобы найти номер столбца Chocolate (шоколадное), снова воспользуйтесь функцией MATCH (ПОИСКПОЗ):

    =MATCH(G3,B1:D1,0)
    =ПОИСКПОЗ(G3;B1:D1;0)

  3. Чтобы найти продажи шоколадного мороженого в феврале, используйте функцию INDEX (ИНДЕКС):

    =INDEX(B2:D13,H2,H3)
    =ИНДЕКС(B2:D13;H2;H3)

  4. А теперь совместите все:

    =INDEX(B2:D13,MATCH(G2,A2:A13,0),MATCH(G3,B1:D1,0))
    =ИНДЕКС(B2:D13;ПОИСКПОЗ(G2;A2:A13;0);ПОИСКПОЗ(G3;B1:D1;0))

Урок подготовлен для Вас командой сайта office-guru.ru
Источник: http://www.excel-easy.com/examples/two-way-lookup.html
Перевел: Антон Андронов
Правила перепечатки
Еще больше уроков по Microsoft Excel



Отзывы (через Facebook):

Оставить отзыв с помощью аккаунта FaceBook:

Спринг Офис - все об офисных принадлежностях и офисных приложениях. Хотите понять, зачем нужны термоэтикетки, или как удалить переносы строк в Excel? Это к нам!