Суммирование наибольших чисел в Excel - Microsoft Excel для начинающих > Спринг Офис
Спринг Офис    

Суммирование наибольших чисел в Excel - Microsoft Excel для начинающих


Этот пример демонстрирует, как создать формулу массива, которая суммирует наибольшие числа в диапазоне.

  1. Используем функцию LARGE (НАИБОЛЬШИЙ). Чтобы найти, к примеру, второе по величине число, нужно ввести следующую формулу:

    =LARGE(A1:A11,2)
    =НАИБОЛЬШИЙ(A1:A11;2)

  2. Чтобы суммировать 4 наибольших числа, добавим функцию SUM (СУММ) и заменим 2 на {1;2;3;4}.

    =SUM(LARGE(A1:A11,{1,2,3,4}))
    =СУММ(НАИБОЛЬШИЙ(A1:A11;{1;2;3;4}))

  3. Закончим нажатием Ctrl+Shift+Enter.

    =SUM(LARGE(A1:A11,{1,2,3,4}))
    =СУММ(НАИБОЛЬШИЙ(A1:A11;{1;2;3;4}))

Примечание: Cтрока формул показывает, что это формула массива, заключая её в фигурные скобки {}. Их не нужно вводить самостоятельно. Они исчезнут, когда вы начнете редактировать формулу.

Пояснение:

  • Диапазон (массив констант), созданный с помощью функции LARGE (НАИБОЛЬШИЙ), хранится в памяти Excel, а не в ячейках листа.
  • Массив констант выглядит следующим образом: {22;10;8;6}.
  • Этот массив констант используется в качестве аргумента для функции SUM (СУММ), давая результат 46.

Урок подготовлен для Вас командой сайта office-guru.ru
Источник: http://www.excel-easy.com/examples/sum-largest-numbers.html
Перевела: Ольга Гелих
Правила перепечатки
Еще больше уроков по Microsoft Excel



Отзывы (через Facebook):

Оставить отзыв с помощью аккаунта FaceBook:

Спринг Офис - все об офисных принадлежностях и офисных приложениях. Хотите понять, зачем нужны термоэтикетки, или как удалить переносы строк в Excel? Это к нам!