Считаем будние и рабочие дни в Excel - Microsoft Excel для начинающих > Спринг Офис
Спринг Офис    

Считаем будние и рабочие дни в Excel - Microsoft Excel для начинающих


Из этого урока вы узнаете, как получить день недели по дате в Excel и как подсчитать количество будних/рабочих дней между двумя датами.

Функция ДЕНЬНЕД

  1. Функция ДЕНЬНЕД (WEEKDAY) в Excel возвращает число от 1 (воскресенье) до 7 (суббота), представляющее номер дня недели. Судя по всему, 16 декабря 2013 в формуле ниже выпадает на понедельник.

    =WEEKDAY(A1)
    =ДЕНЬНЕД(A1)

  2. Ещё для отображения дня недели можно использовать функцию ТЕКСТ (TEXT).

    =TEXT(A1,"dddd")
    =ТЕКСТ(A1;"дддд")

  3. Создайте пользовательский формат даты (дддд), чтобы отобразить название дня недели.

Функция ЧИСТРАБДНИ

  1. Функция ЧИСТРАБДНИ (NETWORKDAYS) возвращает количество будних дней (исключая выходные) между двумя датами.

    =NETWORKDAYS(A1,B1)
    =ЧИСТРАБДНИ(A1;B1)

  2. Если вы укажете список праздников, то функция ЧИСТРАБДНИ (NETWORKDAYS) вернёт количество рабочих дней (не считая выходных и праздничных дней) между двумя датами.

    =NETWORKDAYS(A1,B1,E1:E2)
    =ЧИСТРАБДНИ(A1;B1;E1:E2)

    Календарь ниже поможет вам лучше понять функцию ЧИСТРАБДНИ (NETWORKDAYS).

  3. Excel хранит даты в виде чисел и подсчитывает количество дней с 0 января 1900 года. Вместо того, чтобы подставлять диапазон ячеек в формулу, подставьте константы чисел, которые представляют эти даты. Чтобы это сделать, выделите E1:E2 в формуле ниже и нажмите F9.

    =NETWORKDAYS(A1,B1,{41633;41634})
    =ЧИСТРАБДНИ(A1;B1;{41633;41634})

Функция РАБДЕНЬ

  1. Функция РАБДЕНЬ (WORKDAY) почти противоположна функции ЧИСТРАБДНИ (NETWORKDAYS). Она возвращает дату до или после указанного количества будних дней (выходные исключены).

    =WORKDAY(A1,B1)
    =РАБДЕНЬ(A1;B1)

Примечание: Функция РАБДЕНЬ (WORKDAY) возвращает порядковый номер даты. Примените формат даты к ячейке для её отображения.

Календарь ниже поможет вам лучше понять функцию РАБДЕНЬ (WORKDAY).

Опять же, если вы подставите список праздников, функция РАБДЕНЬ (WORKDAY) вернёт дату до или после указанного количества рабочих дней (исключая выходные и праздничные дни).

Урок подготовлен для Вас командой сайта office-guru.ru
Источник: www.excel-easy.com/examples/weekdays.html
Перевела: Ольга Гелих
Правила перепечатки
Еще больше уроков по Microsoft Excel



Отзывы (через Facebook):

Оставить отзыв с помощью аккаунта FaceBook:

Спринг Офис - все об офисных принадлежностях и офисных приложениях. Хотите понять, зачем нужны термоэтикетки, или как удалить переносы строк в Excel? Это к нам!